
TI mmWave Training 

mmWave Demo 

NOTE: ES3.0 devices only 

This version of the mmWave Demo lab will work only with xWR1443BOOST ES3.0 EVMs, which require mmWave SDK version 2.1 

or above. Please look at the next slide for information on identifying the version of the device on your EVM. 

To download past versions of mmWave Industrial Toolbox which support ES2.0 EVMs, please follow the directions provided 

under How to access previous Industrial Toolbox versions at the bottom of the Industrial Toolbox landing page 

 

http://dev.ti.com/tirex/#/?link=Software%2FmmWave%20Sensors%2FIndustrial%20Toolbox
http://dev.ti.com/tirex/#/?link=Software%2FmmWave%20Sensors%2FIndustrial%20Toolbox
http://dev.ti.com/tirex/#/?link=Software%2FmmWave%20Sensors%2FIndustrial%20Toolbox
http://dev.ti.com/tirex/#/?link=Software%2FmmWave%20Sensors%2FIndustrial%20Toolbox
http://dev.ti.com/tirex/#/?link=Software%2FmmWave%20Sensors%2FIndustrial%20Toolbox
http://dev.ti.com/tirex/#/?link=Software%2FmmWave%20Sensors%2FIndustrial%20Toolbox
http://dev.ti.com/tirex/#/?link=Software%2FmmWave%20Sensors%2FIndustrial%20Toolbox


How to identify ES Version 

A. If the EVM has an “ES3.0” sticker, the device version is ES3.0 

OR 

B. The device marking can be checked as noted in the device errata 

 

 

 

 

 

 

• If the part identifier reads “964FC" (highlighted in red and yellow), the device version is ES3.0 
– This version of the lab is compatible with your EVM. 

• If the part identifier reads “964D", the device version is ES2.0 
– This version of the lab is NOT Compatible with your EVM. Please download a previous version. 
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http://www.ti.com/lit/er/swrz074b/swrz074b.pdf
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Lab Overview 

• Configurable visualization tool for 

processed radar data  

• The following plots are available: 

− Scatter Plot 

− Range Profile 

− Noise Profile 

− Range Azimuth Heat Map 

− Range Doppler Heat Map 

− Statistics 
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1. Requirements 

• Software 

– Pre-requisites 

• Latest TI mmWave SDK and all related dependencies 

installed as mentioned in the mmWave SDK release notes. 

– Google Chrome with TI Cloud Agent Extension 

• For running the mmWave Demo Visualizer 

• Download from TI Cloud Agent or install when accessing 

the demo 

– mmWave SDK Demo  

• Download from TI Resource Explorer 

– UniFlash 

• For flashing firmware images onto  

• Download from TI.com/tool/uniflash 

– XDS110 Drivers 

• For EVM XDS device support 

• Included with CCS Installation, or standalone through TI 

XDS Emulation Software 

• Hardware 

– xWR14xx EVM 

– Micro USB cable (included in the EVM package) 

– 5V/2.5A Power Supply 

• Purchase from Digikey 
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https://www.google.com/chrome/
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1. Pre-requisites 

• Please install the TI mmWave 
SDK version mentioned in the 
table and all the required tools as 
mentioned in the mmWave SDK 
release notes.  

 

– The mmWave SDK release notes 
include the links for downloading 
the required tools. 

 

 

• If you have already installed the 
mmWave SDK and all the 
required tools, you can move on to 
the next step i.e. downloading the 
lab on to your machine. 
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1. Install Pre-requisites 2 3 4 5 

Tool Version Download Link 

mmWave SDK 2.1.0.4 download link 

CCS 8.1.0 download link 

TI SYS/BIOS   6.53.02.00 Included in mmwave sdk installer 

TI ARM Compiler 16.9.6.LTS Included in mmwave sdk installer 

TI CGT Compiler 8.1.3 Included in mmwave sdk installer 

XDC  3.50.04.43 Included in mmwave sdk installer 

C64x+ DSPLIB  3.4.0.0 Included in mmwave sdk installer 

C674x DSPLIB  3.4.0.0 Included in mmwave sdk installer 

C674x MATHLIB (little-
endian, elf/coff format) 

3.1.2.1 Included in mmwave sdk installer 

mmwave device support 
packages 

1.5.9 or later Upgrade to the latest using CCS update process (see SDK user guide 
for more details) 

TI Emulators package 7.0.188.0 or later Upgrade to the latest using CCS update process (see SDK user guide 
for more details) 

Uniflash  latest Uniflash tool is used for flashing xWR1xxx devices 
Cloud version (Recommended): 
https://dev.ti.com/uniflash 
Offline version: 
http://www.ti.com/tool/uniflash 

mmWave Demo Visualizer latest TI Gallery APP for configuring mmWave sensors and visualizing the 
point cloud objects generated by the mmWave SDK demo 
https://dev.ti.com/mmWaveDemoVisualizer 

http://software-dl.ti.com/ra-processors/esd/MMWAVE-SDK/latest/exports/mmwave_sdk_02_01_00_04-Windows-x86-Install.exe
http://processors.wiki.ti.com/index.php/Download_CCS#Code_Composer_Studio_Version_8_Downloads
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2. Download the Lab project 

• The mmWave projects are available 
under mmWave Sensors ► 
Industrial Toolbox in CCS 
Resource Explorer. 

 

• To download the mmWave demo, 
start CCS v8.1.0 and select View ► 
Resource Explorer to open the 
Resource Explorer. 

 

• In the Resource Explorer Window, 
select Software ► mmWave 
Sensors ► Industrial toolbox ►  
Labs. 
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2. Download - continued 

• Select the 14xx mmWave SDK 
demo in the left view. 

 

• The right view shows the contents of 
the Lab which contains the CCS 
Project and the PC GUI. 

 

• Click on the Download and Install 
button       in the top right corner as 
shown. 

 

• Select the Make Available Offline 
option from the drop down to start 
downloading the Lab.  
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2. Download - continued 

• The project will be downloaded in 
C:\ti\mmwave_industrial_toolbox_<ver> 

 

• Select the CCS Project file in the left view 

 

• Click on the Import to IDE       button which 
should be visible in the right side view after 
a successful download. 

 

• This copies the project in the user’s 
workspace and imports it into the CCS 
project explorer. 

 

– It is important to note that the copy created in 
the workspace is the one that gets imported in 
CCS. The original project downloaded in 
mmwave_industrial_toolbox is not modified. 

11 

1 
2 

Download Demo project 
3 4 5 

Click here 

to import the 

project 



2. Download - continued 

• After successfully completing the Import to 

IDE operation, the project should be visible in 

CCS Project Explorer as shown here. 

 

• At this point, we have successfully 

downloaded the mmWave demo and imported 

it in CCS. 

 

• We are ready  to move on to the next step i.e. 

Building the project.  
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3. Build the Lab 

• With the mmw project selected in Project Explorer, right click 
on the project and select Rebuild Project. 

 
– Selecting Rebuild instead of Build ensures that the project is 

always re-compiled. This is especially important in case the 
previous build failed with errors. 

 

• On successful completion of the build, you should see the 
output in CCS console as shown here and the following two 
files should be produced in the project debug directory 

 

– xwr14xx_mmw_demo_mss.xer4f 

– xwr14xx_mmw_demo.bin 

 

• If the build fails with errors, please ensure that all the pre-
requisites are installed as mentioned in the mmWave SDK 
release notes. 

 
– Please note that pre-built binary files, both .xer4f and .bin, are 

provided with the demo under mmwave SDK. 

– Look under 
<mmwave_sdk_install_dir>\packages\ti\demo\xwr14xx\mmw 
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4.1 Preparing the EVM 

•  There are two ways to execute the compiled code on the EVM: 

– Deployment mode: Flashing the binary (.bin image) on to the EVM serial flash 

• In this mode, the EVM boots autonomously from flash and starts running the bin image. 

– Debug mode: Downloading and running the executable (.xer4f image) from CCS. 

• You will need to flash a small CCS debug firmware on the EVM (one time) to allow 
connecting with CCS. This debug firmware image is provided with the mmWave SDK. 

– As a recap, the build process in Step 3 produces both the .bin and .xer4f images. 

 

• This presentation explains the second method i.e. Debug mode (CCS).  

– To prepare the EVM for debug mode, we start with flashing the CCS debug firmware 
image. 

– Please note that the same flashing process can be used to flash the Lab binary to run 
it in deployment mode. 
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4.2 Connecting to the EVM 

• Power on the EVM using a 5V/2.5A power 
supply. 

• Connect the EVM to your PC and check the 
COM ports in Windows Device Manager 

• The EVM exports two virtual COM ports as 
shown below: 

– XDS110 Class Application/User UART 
(COMUART): 

• Used for passing configuration data and 
firmware to the EVM 

– XDS110 Class Auxiliary Data Port (COMAUX) 

• Used to send processed radar data output 

• Note the COMUART  and COMAUX port 
numbers, as they will be used later for 
flashing and running the Lab. 
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COMUART: COM38      COMAUX: COM39 

• The actual port numbers on your machine 

may be different  
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4.3 Flashing CCS debug firmware 
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1. Put the EVM in flashing mode by connecting 

jumpers on SOP0 and SOP2 as shown in the 

image. 

2. Open the UniFlash tool 

3. In the New Configuration section, locate 

and select the appropriate device (xWR14xx) 

4. Click Start  to proceed  
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4.3 Flashing CCS debug firmware 
5. In the Program tab, browse and locate the binary as shown below: 

 

 

 

 

 

 

6. In the Settings & Utilities tab, fill the COM Port text box with the Application/User UART COM port number 

(COMUART) noted earlier 

1.   

 

 

 

7. Return to the Program tab, power cycle the device and click on Load Images 

8. When the flash procedure completes, UniFlash’s console should indicate: [SUCCESS] Program Load completed 

successfully 

9. Power off the board and remove the jumper from only header SOP2 (this puts the board back in functional mode) 
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5.1 Connecting EVM to CCS 

• It is assumed that you were able to download 
and build the Lab in CCS (completed steps 1, 2 
and 3) 

• To connect the Radar EVM to CCS, we need to 
create a target configuration 
– Go to File ► New ► New Target Configuration 

File 

– Name the target configuration accordingly and 
check the “Use shared location” checkbox. 
Press Finish 

– In the configuration editor window: 
• Select “Texas Instruments XDS110 USB Debug 

Probe” for Connection 
• Select IWR1443 or AWR1443 in the Board or 

Device list 
• Press the Save button to save the target 

configuration. 
• You can press the Test Connection button to 

check the connection with the board. 
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5.1 Connecting - continued 

• Go to View ► Target Configurations to open 
the target configuration window.  

 

• You should see your target configuration under 
User Defined configurations. 

 

• Right click on the target configuration and select 
Launch Select Configuration. 

 

• This will launch the target configuration in the 
debug window. 

 

• Select the Texas Instruments XDS110 USB 
Debug probe and press the Connect Target 
button 
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5.2 Loading the binary 

• With the target connected, click on the 

Load button in the toolbar.  

• In the Load Program dialog, press the 

Browse Project button . 

• Select the lab executable (.xer4f) as 

shown and press OK. 

• Press OK again in the Load Program 

dialog. 
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5.3 Running the binary 

• With the executable loaded, press the 

Run/Resume button 

 

• The program should start executing and 

generate console output as shown. 
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5.4 Running the Lab GUI 

1. Using Google Chrome, navigate to the following URL: 

https://dev.ti.com/mmWaveDemoVisualizer 
– Alternatively, go to https://dev.ti.com/gallery and search for “mmWave Demo Visualizer” 

2. If prompted, follow the on-screen instructions for installing TI Cloud Agent 

3. Once the demo is loaded, go to Options → Serial Port  

4. In the serial port window, enter the appropriate port in each of the drop down menus based 

on your port numbers from Step 2 
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5.4 Running GUI - continued 

5. Click on Configure and the demo will automatically connect to the EVM 

– Not connected:   Connected: 

– If the connection fails, try clicking on the connection icon in the bottom left corner 

6. Select the appropriate mmWave device from the Platform dropdown menu 

7. Use the available options to create the desired configuration 

– Additional details about the configuration parameters can be found in the mmWave 
Demo Visualizer User Guide  

8. When ready to send the configuration, click on Send Config To mmWave 
Device 

9. Click on the Plots tab to view the plots that were selected to be shown 

10.Move a highly reflective object in front of the EVM and see how the demo 
responds 
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5.4 Running GUI - continued 
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Learn more about TI mmWave Sensors 

• Learn more about xWR1x devices, please visit the product pages 

– IWR1443: http://www.ti.com/product/IWR1443 

– IWR1642: http://www.ti.com/product/IWR1642 

– AWR1443: http://www.ti.com/product/AWR1443 

– AWR1642: http://www.ti.com/product/AWR1642 

• Get started evaluating the platform with xWR1x EVMs, purchase EVM at 

– IWR1443 EVM: http://www.ti.com/tool/IWR1443BOOST 

– IWR1642 EVM: http://www.ti.com/tool/IWR1642BOOST 

– AWR1443 EVM: http://www.ti.com/tool/AWR1443BOOST 

– AWR1642 EVM: http://www.ti.com/tool/AWR1642BOOST 

• Download mmWave SDK @ http://www.ti.com/tool/MMWAVE-SDK 

• Ask question on TI’s E2E forum mmWave Sensors forum @ 

https://e2e.ti.com/support/sensor/mmwave_sensors/ 
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